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Program will not open after installing the Windows 10 update

Created on  | Last modified on 

Summary

Sage 50—U.S. Edition does not open after installing the Windows 10 Spring Creators Update version 1803 Program starts to open and then closes with no error message Problem affects Windows 10 v1803 workstations in a network environment, server is not affected May also receive error: "You Cannot Use Sage 50 right now because the serial number(s) you have...are already in use by the maximum number of computers" (typically in environments with both Windows 10 v1803 server and workstations) Also Windows 10 Version 10.0.17134 Build 17134

Description

Cause

  • This issue has been determined to have been caused by a defect in the 1803 Spring Creators Update for Windows 10, and will be fixed in a future Windows 10 update.
  • Just installed or updated to Sage 20 US 2020.2 release

Resolution

CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions. 

Option 1: Turn off Compatibility Mode and end task on running Peachw.exe processes:

  1. Right-click the Sage 50 Accounting desktop icon and select Properties.
  2. Click the Compatibility tab.
  3. Un-check the box next to Run this program in compatibility mode for.
  4. If the option is grayed out, check Change settings for all users at the bottom
  5. Click OK.
  6. Press Ctrl + Alt + Delete, then select Start Task Manager.
  7. Browse to the Details tab at the top. Note: If it is not visible, click More Details on the bottom of the Processes tab.
  8. Look for peachw.exe.
  9. Select the process and click End Task at the bottom. If you do not see peachw.exe skip to the next step.
  10. Try to open the program again.
  11. If the program still does not open, restart your computer and try to open again.

Option 2: Remove Run As Administrator

  1. Right-click on the Sage 50 product icon on the desktop
  2. Select Properties
  3. Select the Compatibility tab
  4. Uncheck the box next to Run this program as an administrator. If the box is checked but grayed-out, then click Change settings for all users button at the bottom of the screen, and uncheck it from that secondary window.
  5. Select Apply and OK

Option 3: Set Windows to prefer IPv4 address over IPv6 on the server and workstation

Option 4: If using static IP address, edit the hosts file on the workstation(s)

  • Follow the steps in Article ID 79571: DocLink: How to add a hosts file entry
  • Please consult your local IT staff for assistance in making these changes

Option 5: Incorrectly configured DNS

  • Consult your local IT staff or network administrator before making any changes, and have them verify that DNS is configured correctly
  • If you are using a static IP address/DNS, on the server try changing your Internet Protocol Version 4 (TCP/IPv4) properties to Obtain an IP address automatically and Obtain DNS server address automatically
DocLink: When I click the icon, the program either hangs on gray screen or does nothing at all
DocLink: Program opens, then immediately crashes on standalone workstation

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