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Error: "Unable to login to SMTP connection" and "Failed to get response to login password" when sending Test e-mail from Company Maintenance

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Summary

Error: "Unable to login to SMTP connection" and "535" and "Failed to get response to login password" when sending Test e-mail from Company Maintenance in Sage 100 Cannot set up two-factor authentication for Paperless Office Electronic Delivery Partial Chilkatlog error information below, with relevant information in bold text : Unable to login to SMTP connection. ChilkatLog: VerifySmtpLogin: DllDate: Jan 19 2012 UnlockPrefix: SBestSoftMAILQ Username: Architecture: Little Endian; 32-bit Language: ActiveX ... login_method: LOGIN 535 Incorrect authentication data Failed to get response to login password OR login_method: LOGIN 535 5.7.3 Authentication unsuccessful Failed to get response to login password OR 535 user has been restricted (no detailed error message except 535, this can be due to a wrong email account password on Company Maintenance Email information). Failed to get response to login password OR 535-5.7.8 SMTP Authentication Error "Username and Password not accepted" (535 5.7.8) OR SmtpCmdResp: 535-5.7.8 Username and Password not accepted. Learn more at SmtpCmdResp: 535 5.7.8 https://support.google.com/mail/?p=BadCredentials

Description

Two-Factor Authentication

Sage 100 2021 and higher:

  • Per the Release Notes on "What's New" in Sage 100 2021, “Sage 100 now offers Oauth to authenticate SMTP email requests. Sage 100 customers who use email providers like Gmail or Outlook which require 2-step authentication can now use those email providers directly in the system.”
    • In Sage 100, Library Master, Main menu, Company Maintenance, E-mail tab, select Authentication Method “Oauth” and enter the requisite information.

Sage 100 2020 and before

  • On versions of Sage 100 2020 and before, with Office 365 multi-factor authentication enabled on an account, authentication will fail via Sage 100 as there is not a way to pass the additional authentication needed. An alternative is to use either another Office 365 account, without multi-factor authentication enabled, or another email configuration without multi-factor authentication enabled (such as client's Gmail, Yahoo mail, etc.) would need to be chosen and configured in Company Maintenance as a workaround.

(from Microsoft) To create app passwords using the Office 365 portal:
Sign in to your work or school account, go to the My Account page, and select Security info.
Select Add method, choose App password from the list, and then select Add.
Enter a name for the app password, and then select Next.

Manage app passwords for two-step verification
https://support.microsoft.com/en-gb/account-billing/manage-app-passwords-for-two-step-verification-d6dc8c6d-4bf7-4851-ad95-6d07799387e9

Multifactor authentication for Microsoft 365
https://docs.microsoft.com/en-us/microsoft-365/admin/security-and-compliance/multi-factor-authentication-microsoft-365?view=o365-worldwide

Security defaults is a new feature for Microsoft 365 and Office 365 paid or trial subscriptions created after October 21, 2019. These subscriptions have security defaults turned on, which:

  1. Requires all of your users to use MFA with the Microsoft Authenticator app.
  2. Blocks legacy authentication

Cause

The SMTP server is not responding to the login and password information provided.

Resolution

CAUTION: This solution requires advanced knowledge of your network. Contact your system administrator for assistance. Modifying Windows security incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows security. Always create a backup of your data before proceeding with advanced solutions. 
CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions. 
CAUTION: Sage Customer Support does not assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Please get in touch with your Sage business partner, network administrator, or accountant for assistance. Please refer to our Scope of Support document for details.

Note: There are numerous different server programs and providers that provide the services of an SMTP e-mail server. Sage does not test Sage 100 with all e-mail services/programs/providers. Sage 100 Customer Support is not responsible for knowing the exact combination of program or provider, security or permission settings, inbound or outbound rules, account logins, passwords, bandwidth restrictions, etc. to enable successful e-mail delivery. The specifics of services, programs, and providers are subject to change. If an error is encountered, troubleshoot based on the Chilkat error log information. You may need to try various settings, or test an alternate service, program, or provider.

Possible Resolutions:

  • Check and verify the login and password
    • Note: The password field appears to allow more characters but only holds 14 characters in Sage 100 versions prior to the 2016 version
      • Note: If the password is more than 14 characters, the password may be cut off in versions of Sage 100 prior to the 2016 version, causing password authentication to fail. You can try shortening the length of the e-mail password via the SMTP provider's e-mail settings, then enter that new password on in the E-mail tab of Library Master, Company Maintenance in Sage 100
  • If the login and password are correct, enable and check the SMTP server's log (you may have to contact the SMTP provider to request) to see what the handshake attempt looks like
    • Troubleshoot based on the information from the log
    • Check if the SMTP server has properly set inbound rules to allow for multiple login/connection attempts. Some SMTP servers do not allow more than a certain number of connections per time periods.
  • If getting "Username and Password not accepted" 535 5.7.8 error, but user name and password work logging onto email via web (with 2-factor authentication), you may need to enable "Access for less secure apps" (allow exceptions to 2-factor authentication) in your email settings.
    • For example, for Gmail:
  1. Login into your account Gmail or Google Apps then goto:https://www.google.com/settings/security/lesssecureapps
  2. and select Turn On for Access for less secure apps.

If 2-Step Verification is enabled for the Gmail account, App Password may be used. See Related Resources for How to configure Gmail with Paperless Office.

DocLink: How to configure Gmail for use with Paperless Office, Electronic Delivery on Sage 100 2013 and higher
DocLink: Where to enter SMTP E-mail Server address, encryption, and login settings for Paperless Office Electronic Delivery