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Program is very slow to open

Created on  | Last modified on 

Summary

Sage 50 takes a long time to open; all companies, including the sample companies, are very slow to open.

Cause

  • Incorrectly configured DNS
  • Winlogon errors
  • User Account Control (UAC) enabled
  • Incorrect mapped drive
  • DNS Relay is enabled on the router

Resolution

CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions. 
CAUTION: Sage Customer Support does not assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Please get in touch with your Sage business partner, network administrator, or accountant for assistance. Please refer to our Scope of Support document for details.


Section 1: Incorrectly configured DNS

  • IMPORTANT: Changing these settings can interfere with the network's LAN properties. Contact your local IT or Network Administrator before proceeding, as interfering with the LAN properties could break something in another product and/or keep users from connecting back to the network at all.
  • Note: On a network, these steps must be performed at the server.
  1. Change the DNS settings to Automatically Detect Settings.
  2. Verify that the program is no longer slow to open.

Section 2: Check for Winlogon errors in Event Viewer

  1. Click Start, and in the Search box or Run box, type eventvwr.
  2. Double-click Windows Logs, and then double-click Application.
  3. Check for a red error message with a date from after the program last opened that gives the Source as winlogon.
  4. If a winlogon error is present, log out of Windows and log in under a new profile. If the program opens quickly under this profile, this indicates that the other Windows profile was damaged. If it is still very slow to open, proceed to the next section.

Section 3: Uninstall and Reinstall Sage 50—U.S. Edition

  1. Completely uninstall Sage 50; refer to How to manually remove the program
  2. Reinstall Sage 50; refer to Installation Instructions - Sage 50—U.S. Edition
  3. Verify the program and companies open normally.

Section 4: Run as an administrator

  1. Right-click the Sage 50 shortcut.
  2. Select Run as administrator.
  3. Verify that program opens quickly.

Section 5: Set Windows to prefer IPv4 address over IPv6

  1. Please refer to  How to set Windows 10 to prefer IPv4 over IPv6
  2. Verify that the program opens quickly.

Section 6: Remap the network drive

  1. Disconnect and remap the network drive using only the server name (Do not map by IP address or use UNC path in Sage 50). See How to map a network drive
  2. Verify that the program is not slow to open.

Section 7: Verify that Pervasive/Actian is running

  1. Open Run and type Services.msc
  2. Select OK
  3. Scroll to Pervasive PSQL Workgroup Engine (for Sage 50 2019 and lower) or Actian PSQL Workgroup Engine (for Sage 50 2020 and higher) and verify that it is Started or Running
  4. If Pervasive/Actian is not Started, right-click Pervasive or Actian PSQL Workgroup Engine, and then select Start
  5. Verify that Sage 50 starts normally





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