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Error "Sage 50 has found a problem in your company file and is unable to upgrade it (MySQL5.6.10)"

Created on  | Last modified on 

Cause

  • Some invalid tables exist in the database, these tables will cause the conversion fail

Resolution

 Method 1: Open Sage 50 and run it as an administrator

  1. On your desktop, right-click on the Sage 50 Accounting shortcut icon.
  2. Select Run as Administrator.
  3. Continue and try to convert your company file again.

Method 2: Copy the data file to the C:\ Drive

  1. Create a copy of the company file and save it on the root of the C drive.

Method 3: Check the .SAJ data folder

  1. Check inside the .SAJ, mysql and simply folder for any files with a (1) beside them, or a duplicate file with a hex number behind it such as ibdata1 - 0ac2fe50...., and delete those files.
  2. Check inside the .SAJ, if the folder mysql and simply folder name is changed to Title case (the first letter of folder name is in capitals) and all the files inside the SAJ and mysql and simply folders -rename those file and folder names to smaller case.
  3. Check for permissions on the location where the files are saved.
  4. Make sure there are no hidden/read-only files in the .SAJ folder.

Method 4: Give read/write access to the sysadmin user

  1. Open the data file in the previous version of Sage 50.
  2. Give the sysadmin user Read/Write Access under Setup, Set Up Users.

Method 5: Do an Advance Database Check

  1. Open the company file from the previous version of Sage 50 (ex: 2013 instead of 2014)
  2. Under the Maintenance menu, select Advanced Database Check.
  3. During the verification, if you are asked to repair, please do so.
  4. If you are unable to open the company file from the previous version of Sage 50: Select Windows Start, Programs, Sage, Sage 50, then Company File Check & Repair.
    • If your previous version is not 2013, then use your version's option for Company File Check and Repair.
  5. The window 'Sage 50 Company File Check & Repair' appears.
  6. Select Browse.
  7. Browse to the location of your company file on your computer (.SAI) and select it.
  8. Select Open.
  9. Select Advanced Check & Repair.
  10. If you are asked for the password for the sysadmin user, then enter it and select OK.

    Note: If you don't have a sysadmin password, skip this section and continue.

  11. Proceed with the verification and any repair notifications until done.
    1. Note: You will see the 'Sage 50 Company File Check & Repair' window when done.

  12. Close the previous version of Sage 50.
  13. Open the current version Sage 50.
  14. Try to convert the company file again with the current version of Sage 50.


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