Skip to content
logo Knowledgebase

Unable to save maintenance records

Created on  | Last modified on 

Summary

Unable to save changes in maintenance records, such as employees, vendors, and customers.

Cause

  • Sage 50—U.S. Edition running in Compatibility Mode
  • Damaged files from a failed data conversion
  • Incorrect program path

Resolution

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.



Note: Verify all machines are on the same version and Service Release. Reboot the computer that is having this issue, and if you just recently converted, then restore the backup made prior to converting into a new company before attempting any of the steps below. Refer to How to restore a backup.

Section 1: Sage running in Compatibility Mode

  1. Close Sage
  2. Right-click Sage icon and select Properties
  3. Click Compatibility tab
  4. Select Change settings for all users box
  5. Clear Run this program in compatibility mode for box
  6. Click Apply, then click OK and then Click OK again.
  7. Open your company in Sage 50 and verify if issue is resolved
  8. If still unresolved, then continue to next section

Section 2: Disable Tablet PC Input Services

  1. Close Sage
  2. Press Windows + R keys on your keyboard
  3. Type services.msc, and then click OK
  4. Double-click Tablet PC Input Service or Touch Keyboard and Handwriting Panel Service
  5. Stop the service
  6. Double-click Tablet PC Input Service or Touch Keyboard and Handwriting Panel Service and then go to Properties
  7. Change Startup type to Disabled
  8. Select Recovery tab; change all options to Take no action, and then click OK
  9. Close Services menu
  10. Open Sage and verify that program no longer closes

Section 3: Damaged files

  1. Select Maintain, and then select Company Information
  2. Copy the company's Directory at the bottom
  3. Close Sage
  4. Press the Windows+R keys to load a run command
  5. Paste the directory into the run command and click OK
  6. Delete all files with the extension .DDF (should be 12) and COSESS.DAT
  7. Open Sage and your company

Note: If you receive Error: "Sage 50 Accounting has stopped working" when you open the company, refer to Error: “The file [Directory]\Reports\DDF.zip was not found”.

  1. Verify you are now able to save the record.

Section 4: Only 10 DDF files are recreated after deleting them in Section 3

  1. Replace Actian by following How to completely remove and reinstall Actian (formerly Pervasive).
  2. Repeat steps in Section 3.
  3. Verify you can open your company without error and now are able to save the record

Section 5: Damaged Reports folder

  1. Exit Sage from all computers
  2. On the computer that hosts the data; browse to the data path by following How to find data path and program path.
  3. Rename Reports to OldReports
  4. Run a repair by following How to run Repair.
  5. Repeat steps in Section 3.
  6. Verify you can open your company without error and now are able to save the record.

Section 6: Damaged Addresses.DAT

  1. Refer to Integrity Check Guide.
  2. Reindex Addresses
  3. Verify you can add new maintenance records; if error persists, continue with steps
  4. If it's happening in one particular record, reindex that DAT file. Example:(Customers, reindex Customer.dat, Vendors - Vendors.dat etc...)

Note: Click OK through any errors until the reindexing is complete. If you receive a lot of errors while reindexing, the company data is corrupted, and you will need to restore a backup from before the problem began. Refer to How to restore a backup.

Section 7: Creating a new directory with the core company data files

  1. Select Maintain, and then select Company Information
  2. Note the Directory for your company
  3. Create a new folder in the data path. See Create a clean data folder and expendable file cleanup.
  4. Verify you can edit and create maintenance records

Section 8: Change another field on the record

  1. Open the vendor's maintenance record
  2. Alter any field such as the Telephone 1 field, and then click Save
  3. Click Change ID, enter the new ID, and then click OK
  4. Verify the new ID is displaying and saving

Section 9: Character limit exceeded

Verify you are not trying to enter more characters than the field allows

Section 10: Damaged data file

  1. Change to Accounting Period 1. Refer to How do I change the accounting period?.
  2. Select File, and then select Data Verification. See How do I load, access, and run Data Verification?
  3. Select Both Tests (recommended), and then click Start

Note: If the test returns a large number of errors, you will need to restore from a prior backup and run the test again.

Section 11: Failed Conversion

Note: Requires older version of Sage 50 installed (Side by Side Installation)

  1. Create backup from older version. See How do I create or make a backup?.
  2. Restore backup in the currently supported version of Sage 50. Refer to How to restore a backup.
  3. Convert company file upon opening; refer to How do I convert my company data?.
  4. Verify you are now able to create a new maintenance record.