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Error: "File system error 3 or 95 in file: [File].DAT."

Created on  | Last modified on 

Cause

  • Ending process on w3dbsmgr.exe while Sage 50—U.S. Edition is running
  • Stopping Actian Database while Sage 50 is running
  • Drop in network connection in a wireless environment
  • Incorrectly set sharing and security permissions
  • Error received after installing Service Release
  • Computer goes to sleep while the application is open, which breaks the connection
  • Damaged userpref.dat file

Resolution

Section 1: Open company after clicking OK

  1. Click OK through all messages.
  2. Verify you can open your company without errors.
  3. If still receive error, a backup will need to be restored. Refer to How to restore a backup
Section 2: Loss of Network connection
  • The workstation losing the connection to the server may cause this error.
  • Refer to Error: "File System Error 3110" for steps to troubleshoot network connectivity issues.
  • Sage 50 may not work properly on wireless networks.

Section 3: Actian Error

If the Actian service was manually stopped, either by ending process on w3dbsmgr.exe or through the Services menu, restart the computer. If the error still occurs, or if the service was not manually stopped, use the following steps:

  1. On the keyboard, press Windows+R keys.
  2. Type services.msc, and then click OK.
  3. Right-click Actian PSQL Workgroup Engine, and then select Start or Restart.

Note: If an error occurs restarting Actian, or if the original error still occurs, refer to How to completely remove and reinstall Pervasive/Actian.

  1. If after reinstalling Actian the error continues to recur, another program or service on the PC is stopping the Actian service. Try rebooting into Selective Startup.Refer to Files to allow through firewall and antivirus.

Section 4: Improperly set sharing permissions

Follow Verify my data file permissions are correctly set.

Section 5: Delete all PTL files

  1. Refer to How to locate company directories.
  2. Locate any PTL files, and then Delete them.

Section 6: Computer enters sleep mode

  1. You will receive this error if your computer enters sleep mode while the program is open.
  2. Be sure to close Sage 50 before you walk away from your computer for any amount of time that would cause the computer to enter sleep mode.

Section 7: Damaged Userpref.dat file

  1. Refer to How to locate company directories.
  2. Locate the Userpref.dat file, and then rename it to Userpref.old.