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Error: "Payment not found" when posting Bank Reconciliation after a Number Change.

Created on  | Last modified on 

Summary

The following message appears when posting Bank Reconciliation: "Payment not found." Previously an AP Vendor Number Change, or AR Customer Number Change had been done.

Description

Issue is scheduled to be corrected in the 2021 Product Update 5 release.

Cause

The message indicates corruption in the BKTRAND table where the original Vendor or Customer number had not been updated.

Resolution

CAUTION: These steps require knowledge of database engines and application databases (DBs) used by your Sage product (including Microsoft/Transact SQL, Pervasive SQL, or MySQL, etc.). Customer Support is not responsible for assisting with these steps and cannot be responsible for errors resulting from changes to the database engine or DBs. Before making changes, backup all system and application DBs required for a full restore. Contact an authorized business partner or DB administrator for assistance.

Restore original data. Either by reversing the Vendor or Customer Number Change. Or by restoring the original database.

Defect ID

D-42730