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Error: "A Managed Exception was caught in ShowListView(). The error is 'Exception has been thrown by the target of an invocation.'" when opening a list window

Created on  | Last modified on 

Summary

How to resolve this error.

Cause

  • Latest service release not installed
  • Files in company data set folder are damaged

Resolution

Solution 1:

  1. Install the latest product update on all computers. For information about installing the latest service release follow How to install updates.
  2. Verify that you no longer receive the error; if you do, continue to Solution 2.

Solution 2:

  1. Click Maintain, Company Information.
  2. Write down the information shown on the Directory line.
  3. Close Sage 50 on all computers.
  4. Open Windows Explorer and browse to the location you wrote down in Step 2.
  5. Click View, at the top of the window.
  6. Check the boxes for File name extensions and Hidden items.
  7. In the company directory, locate and delete the following files:

    Note: Verify that ATMNTBDL.DAT and ATTCHMNT.DAT are both 60 kb prior to removing. If these files are larger than 60 kb, the attachment functions may be in use and removal of these files will un-link any attached files from their transactions.
    • ADVDATA.DAT
    • ADVHIST.DAT
    • ALARM.DAT
    • ALERT.DAT
    • ATMNTBDL.DAT
    • ATTCHMNT.DAT
    • COSESS.DAT
    • Userpref.dat
    • All files with .DDF extension
    • All files with .LCK extension
    • All files with .PTL extension
  8. Re-open the company in Sage 50.
  9. Verify that you are able to access the desired List window without error.


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