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Preparing your SQL data prior to upgrading to Replicator 2.0

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Description

Cause

Sage Replicator 2.0 expects a clean SQL Server instance and will cause issues or errors if you already have data from previously replicating.

Resolution

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.
CAUTION: These steps require knowledge of database engines and application databases (DBs) used by your Sage product (including Microsoft/Transact SQL, Pervasive SQL, or MySQL, etc.). Customer Support is not responsible for assisting with these steps and cannot be responsible for errors resulting from changes to the database engine or DBs. Before making changes, backup all system and application DBs required for a full restore. Contact an authorized business partner or DB administrator for assistance.

To remove existing data from your Sage Replicator SQL Server instance, follow these steps:

  1. Launch SQL Server Management Studio (SSMS) on the computer that has your Sage Replicator SQL Server instance, and log into this instance.
  2. Expand "Databases".
  3. You may see the following databases:
    SageCREGlobalConfiguration
    SageApplicationTelemetry
    Izenda
    (your replicated company databases)
  4. To delete a database, right click on the database, select "Delete" and click the "OK" button to confirm. Repeat this step for the first three databases listed in step 3, as well as all of your replicated company databases.
    Note: Do not delete the System Databases or the Database Snapshots, or their folders.
  5. Close SSMS
  6. Open a Windows File Explorer window and browse to the following location:
    C:\Program Files\Microsoft SQL Server\MSSQL13.SAGE300CRE\MSSQL\DATA
    Note: If you installed the SQL Server Database Engine, or configured your SQL Data folder to a different location, use that path.
  7. Verify the database files (.mdf and .ldf) and folders for the databases you deleted in step 4 have been deleted from this directory. If the files still exist in this location, delete them.