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Error: "At least one damaged transaction has been found in account [number] in the period beginning [date]...."

Created on  | Last modified on 

Description


Cause

  • Editing a transaction multiple times can cause the transaction to post incorrectly
  • Damaged transactions
  • Changing an account on a paid or partially paid vendor invoice
  • Changing an account on a paid or partially paid customer invoice

Resolution

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.

  • Section 1: Run Data Verification
    1. Change the accounting period to Period 1; see How do I change the accounting period?.
    2. Select File, and then Data Verification.
    3. Select Both Tests, and then Start.
    4. Save the backup. When the backup completes, the data tests will begin automatically.
    5. If you get the same error during the Data Verification test, skip to Section II.
    6. If you do not receive any errors during the Data Verification test, change the accounting period back to the current period.
    7. Run the General Ledger report. If you still receive the error, proceed to Section II.

    Section 2: Run Integrity Check

    1. Select File, then Backup and make a backup of your company. Put before test in front of the backup name.
    2. Change accounting period to Period 1.
    3. Open the Integrity Check by going to Help, Support Utilities, Integrity Check
    4. Select Continue.
    5. Check Reindex Files.
    6. On the Reindex Files List, select Chart and click OK.
    7. Repeat Steps 2-5 reindexing the following items:
      • Customer
      • Employee
      • Vendor
      • Jrnl Header
      • Jrnl Rows
      Note: Perform test for each file one at a time.
    8. For each test indicated below, repeat Steps 2-3, then select the indicated item and click OK:
      • Customer / Journal
      • Vendor / Journal
      • Employee / Journal
    9. Chart of Accounts / Journal
      Note: During the Data Synchronization tests, it may flag customers, vendors and employees as being corrected; click OK to each message to continue on.
      During the Data Synchronization test for Chart of Accounts if it flags bad transactions:
      • Either write down the Reference number for each indicated entry, or take a screen shot to note which entries are referenced
      • Delete each of the indicated problem transactions and re-enter them
      • Once the transactions listed have been recreated, re-run all the tests again to verify that the transactions are not flagged again and no further synchronization errors occur

    Note: If the damaged transaction is in an Inventory account, step 7 should include Line Item, and step 8 should consist of the Inventory/Journal test.

    Section 3: Converted data from Intuit QuickBooks

    • If you receive the error after converting from QuickBooks, it indicates the data did not convert correctly.
    • View the IntuitConversion.log file to see what went wrong. Repair the data in QuickBooks, and then convert the data again.
    • See the guide Sage 50 Accounting U.S. Edition Converting from QuickBooks.

    Section 4: Consolidated company displays error

    1. Run Data Verification as outlined in Section I in all subsidiary companies. If the error continues in any subsidiary company, refer to Section II.
    2. Afterwards, reconsolidate the consolidated company.
    3. If the problem persists, create a new consolidated company and add one company at a time to see which one is causing the problem.



Related Articles

Integrity Check Guide
How do I consolidate multiple companies for reporting purposes?
How do I reconsolidate my consolidated company?