Summary
It may be necessary to restart the Pervasive/Actian and Sage Service Host services on both the Sage 300 Construction and Real Estate Accounting Server and the workstation(s) receiving the error. Reboot all computers involved or restart services.
Cause
Files locked open by Pervasive/Actian due to computer crash, power loss, and/or abandoned terminal services sessions, etc.
Resolution
Warning: Don’t restart Pervasive/Actian services while operators are using a Sage 300 Construction and Real Estate or Sage Estimating application. If you do, they will lose their network connection to the Pervasive/Actian engine. This causes data corruption.
Notes:
Notes:
- If you use MyAssistant, after restarting Pervasive/Actian services, you must also restart the ISD services on the server. See DocLink: MyAssistant tasks are not sending emails (ISD services need to be restarted).
- Only use this method if you are unable to release a locked file using the Pervasive Monitor Utility. See DocLink: MyAssistant tasks run, but never complete. (multiple causes).
- To restart the Pervasive/Actian and Sage services (on server or terminal server):
- At the server, log on as the administrator.
- Start and click Start Search.
- Type services.msc. Click OK.
- Locate Pervasive/Actian PSQL Relational Engine. Right click and select Stop.
- Repeat for Pervasive/Actian PSQL Transactional Engine and Sage Service Host services
- Note: On a terminal server or workstation there may only be one Pervasive/Actian PSQL Workgroup service
- Right-click each service again. Select Start.
- To restart Pervasive/Actian Engine on a workstation that does not have the Pervasive/Actian service installed (versions 14.1 and older):
- Click Start, All Programs, Pervasive PSQL, Engines, Stop Engine.
- Click Start, All Programs, Pervasive PSQL, Engines, Start Engine.
- Start and click Start Search.
- Type services.msc. Click OK.
- Locate Sage Service Host, right click. Select Restart.
- If you are still receiving errors relating to locked files, you may need to reboot the server and any workstations or terminal servers involved.
Note: To find the Search function in Windows 8:
- On the Start screen, you can tap or click the Search button to open Search. Or if you have a keyboard, just start typing. (If you don't see the Search button on your Start screen, you don't have the latest update for Windows 8.1 and Windows RT 8.1.)
- You can press the Windows logo key + S to open Search. To search for a file on your PC or OneDrive, press the Windows logo key + F. And to search for settings on your PC, press the Windows logo key + W.